Can't get YaCy working on Mint Linux w Vivaldi browser

I’m am clueless where to start. I installed with snap. Then downloaded and started damon still no luck any ideas. All settings suggested in browser error don’t seem to exist. Is there a workin guide for Vivaldi? I also tried with firewall off

I like that there is apparently a kind of universal installer,… that includes YaCy:

That’s fantastic, if it works. Not so great if it doesn’t. I was not familiar with Snap or with Vivaldi.

For me, on Windows, YaCy first opened in Chrome. I could not figure out a way to make it open in Firefox. Eventually I just copy-pasted the URL from Chrome into Firefox, then got a pop-up message (From YaCy ? I think) asking if I wanted to set Firefox as the default browser, and I said yes or OK, though Firefox was already my default on the OS.

It sounds like possibly you’ve already done so, due to your mention of “browser error” but, if you haven’t already done so, I would try using Vivaldi to visit: http://localhost:8090/index.html

You may get a message from YaCy asking if you want to use Vivaldi by default.

I would like to try reproducing the problem but would need a little more info, like which version of Mint, which window manager, anything about the computer hardware, internet connection as well as the specific error messages.

I’ve seen several requests on various Linux forums asking for an OS specific installer, though YaCy is easy enough to install on ANY Linux via command line.

Some clarification about what you have already tried would be helpful. Like “I installed with snap”, do you mean YaCy or Vivaldi, “Then downloaded…” This seems out of order, if YaCy was already installed?

I would try opening YaCy in some other browser by going to http://localhost:8090/index.html in say, Chrome or Firefox. I know YaCy works in either of those. If that works it would at least narrow down the problem. It may be a Vivaldi specific issue.

I mostly use MX Linux.

I will try installing Vivaldi. and see how YaCy works.

There have apparently been issues with getting Linux to recognize Vivaldi as default browser:

Vivaldi is apparently not included in the MX Linux package manager so it seems I’ll need to install from the command line:

Figured it out. I’m a dunce lol Found YaCy folder in home. I started daemon before. ./ is working now. Not sure why but it works! Can’t see any search results though. It shows there are pages of results but all the pages are blank.

Thanks for your help though! Almost forgot my manners lol PS. I have been along time umatrix user. The web is intolerable without it. I believe most aps are spyware. I use 2 and don’t even really trust them

I also went with the download version instead of snapd. KI forgot to remove Snapd version maybe that was the problem

Glad you got it working.

I installed Vivaldi without any issues. Opened http://localhost:8090/index.html in Vivaldi and all seems to be working fine. So YaCy can run in Vivaldi, on Mint or MX Linux

It would be interesting to find out if there is some issue with the Snap installer.

It seemed at first as though I was having the same problem. Following search results seemed to display only a blank screen. I checked and my CPU was pinned at 100% for some time. After a few more tries though this behavior seems to have calmed down.

In general it seems YaCy on Vivaldi, for some reason, uses more CPU than on Firefox.

Vivaldi with Thunderbird freezes up my Pi. I can’t get firewall or router right now. Either port forwarding or firewall is not allowing connection. Also started Kodi by accident. That was frozen on close, might be blank issue

I give up for today. I’ll just be leaching for a little while I hope.

I changed memory setting in Admin/ Performance from 600 MB to 1200 MB. No more blank screens. Still leach only. Can’t figure that one out. I’m calling it ISP blocking lol. Firewall and router claim 8090 is open for my local IP. DMZ made no change. There is a proxy setting. I may play with that. Also when I block 8090 there is no search page so, I’d call that conformation it’s open. I suspect this was my original problem Firewall blocking search. snapd may be ok but not recommended for Mint Linux. Proxy failed too. I’m just a leach for ever, It looks like