How to index intranet with .net domains

I have fresh yacy installation, want to use it for local use only, my intranet uses .net
when i try to index anything, for example mediawiki i get this
“Crawling of “” failed. Reason: denied_(the host ‘’ is global, but global addresses are not accepted:”

it did reach the right host indeed, but how do i make yacy accept my ip or domains as local addresses

i did some googling and didnt reach anything


well, after more reading i can understand that i have to use network.unit.domainlist
i created file called searchme.txt in yacy root dir, add to it

edited defaults/ and added

network.unit.domainlist = seachme.txt

i still cant index

i got ignored i think :frowning:

just how do i format the domainlist, just put the links there? do i need to add something before each line?
YaCy seems to access my domainlist file, but not able to understand it i think?

I tried to make the host file accessible over http, and i get that the file got accessed - - [05/Jun/2020 14:02:27] "GET /allowedsites.txt HTTP/1.1" 200

but still get in YaCy that its not in the domainlist :confused:

YaCy recognizes internet/intranet ranges using the IP after DNS resolving. So if you are using .net TLDs within your intranet, then you must switch to intranet mode.

YaCy differs strictly between internet and intranet indexing because this is a privacy issue.

I am using yacy as an intranet search engine and I get " Crawling of “” failed. Reason: denied_(the host ‘’ is global, but global addresses are not accepted:".
imho the tld .box isn’t global nor the IP.
I started a crawl with this domain after starting yacy for the first time and later I added to /etc/hosts. Later I stopped yacy, moved the directory to another partition and started over. The running crawl wasn’t executed like before. Now I got the error like above and wasn’t able to start a crawl again.

The background: I want to have a server with kiwix, dwww and search engine and want to access it from other local devices. Therefore I can’t run the crawl with Have a look at to see more details.

Using devuan instead of works for me.