Index shared folders

Hi, Im new on Yacy and Im having some issues.
Im trying to index the files of our windows server, when I use smb:// it gives me error, saying its *No parser available in SMB, i think its not connecting, it requires authentication. I tried:

With “file://” wihtout authentication it reaches all folders and index all files, but when i try to acess the files from browser, local or other machine, it doesnt open, the link is messy, there is no IP.

With Fess ( I use the smb:// option with authentication in one former, I dont know how they do the connection.

What am I doing wrong?




Should be the right one. However:

  • I don’t know if %-characters are working there

  • I never tested this with passwords, because

  • passwords would be revealed within search results in clear text and that cannot be something what you want

  • search indexes for smb shares do only make sense if the shared index gets access to a shared account.

In case the shared account has a PW-protection using AD, then the following software may help:

This must be used to mount shares locally for registered users which then can be indexed without a password using a file:/// path.

The authentication layer then sits between the user and the search interface and acts as a filter which makes search results only visible for users which have the correct account rights for that specific path.

That is not a proper URL. A file:// url must have a path after that prefix.
For eample if the path is /home/user/xyz the url is file:///home/user/xyz. (yes, three times ‘/’)

Hi, thanks for the quick answer, and sorry for my lack of knoladgment

I tried the file:/// and it didnt work, but with 5 slashes, file:///// it worked.

but the urls created are not linckable. If I click on it, nothing happens. If I copy the url and paste in other window it works.

It seems it miss slashes in the result when I click with the mouse.

If I get the source code of the search result page and paste in a static html (test.html) and try to open the links, it works.

1 Like

In addition, selecting “open link in new tab” results in a new tab opening to about:blank#blocked This post seems to indicate it may be due to a brave/chromium browser security issue?

Any ideas for a work around on this issue when working with local files? (windows 10/brave)

odd-shaped urls may be usable with plugins. Here is one for example but I did not try it.