Installation problem

I installed yacy on a headless debian 11 server. I untared the tarball into /opt, but had to change the folder permissions to run it as a non-root user.

EDIT: I have been poking around the files and discovered a lot of info in the folder called “defaults”. I’m inclined to wipe this fresh install and start fresh, changing port number etc in defaults before starting yacy for 1st time. Of particular interest is the info about clustering and peer types & sub-types.

I changed the default port, and it does start but I can’t access the admin pages, I get this error when I click the admin link in upper right. This has nothing to do with the port, as I changed it back to 8090 and got the same result.

Running this headless I use an ssh tunnel to forward port 8090, but that too is irrelevant as I get the same error when I connect to that via IP address (http://:8090/).


Message: /opt/yacy/htroot/ConfigBasic.html
javax.servlet.ServletException: /opt/yacy/htroot/ConfigBasic.html
	at net.yacy.http.servlets.YaCyDefaultServlet.handleTemplate(
	at net.yacy.http.servlets.YaCyDefaultServlet.doGet(
	at javax.servlet.http.HttpServlet.service(
	at javax.servlet.http.HttpServlet.service(
	at org.eclipse.jetty.servlet.ServletHolder.handle(
	at org.eclipse.jetty.servlet.ServletHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.eclipse.jetty.server.handler.gzip.GzipHandler.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.session.SessionHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextHandle(
	at org.eclipse.jetty.server.handler.ContextHandler.doHandle(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.servlet.ServletHandler.doScope(
	at org.eclipse.jetty.server.session.SessionHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.nextScope(
	at org.eclipse.jetty.server.handler.ContextHandler.doScope(
	at org.eclipse.jetty.server.handler.ScopedHandler.handle(
	at org.eclipse.jetty.server.handler.ContextHandlerCollection.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at net.yacy.http.CrashProtectionHandler.handle(
	at org.eclipse.jetty.server.handler.HandlerWrapper.handle(
	at org.eclipse.jetty.server.Server.handle(
	at org.eclipse.jetty.server.HttpChannel.lambda$handle$1(
	at org.eclipse.jetty.server.HttpChannel.dispatch(
	at org.eclipse.jetty.server.HttpChannel.handle(
	at org.eclipse.jetty.server.HttpConnection.onFillable(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.runTask(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.doProduce(
	at org.eclipse.jetty.util.thread.strategy.EatWhatYouKill.tryProduce(
	at org.eclipse.jetty.util.thread.ReservedThreadExecutor$
	at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(
	at org.eclipse.jetty.util.thread.QueuedThreadPool$
	at java.base/

I started from scratch, untared the tarball and changed nothing. I changed into the yacy folder and ran ./

netstat -tulpn showed java listening on port 8090. Good so far.

Since I’m running on a headless server without a GUI, I use an ssh tunnel to forward port 8090 to my local computer (ssh -L 8090:111.222.333.444:8090 user@111.222.333.444)

On my local machine I browse to and set the admin account within 10 minutes. Clicked settings gear in upper left corner and logged into admin page. I changed the port and clicked orange Re-Start button.

The main thing is going to the ConfigAccounts_p.html page first. If I go anywhere else after starting the server the above exception occurs.

After the Re-Start I manually checked that a java listener was waiting on the new port. I updated my ssh tunnel and browsed to the same URL but with new port number and I was able to login using the gear / setting icon and no exception occurred.

1 Like