Installing Alpine Linux

Rufus works to get a bootable USB going to run: setup-alpine


Create bootable USB stick from ISO on Windows

Additionally to the method above for Linux systems, there is also the Rufus program available, which allows writing such bootable USB flash drives under Windows.

Note: Rufus has been tested and works on Alpine Linux 3.12.x with the following settings

  • Partition scheme : MBR
  • Target system : BIOS or UEFI
  • File system : FAT32
  • Cluster size : 4096 bytes (default)


If someone wants to brave installing Alpine via Linux entirely on the command line, then they already know way more than I do. I tried, but quickly got lost in the woods.

Rufus worked for me.

Booting up Alpine Linux from the USB drive it gets to

localhost login:

type: root and hit return

Welcome to Alpine

I’m starting this thread mainly to get help, and report progress.

You can setup the system with the command: setup-alpine


type: setup alpine

From there, I found information on this page somewhat helpful:


Enter the following into the prompt of the installer.

Keyboard layout: none (or whatever suits your preference)
Hostname: localhost
Network interface: eth0
IP address: dhcp
Manual network configuration: no
Password: test123
Again password: test123
Time zone: UTC
HTTP proxy: none
NTP client: chrony
Mirror: 1 (or whatever suits your preference)
SSH server: openssh
Setup disk: none
Store configs: none
Apk cache directory: none

Helpful in that I got through the setup process, keyboard, timezone, networking, dhcp, apparently, but I’m not sure this alone produces the results wanted. But I did manage to get my wireless working, get online, contact download mirror, etc. everything going OK, then I end up with a typewriter.

I think because my computer has no hard drive to install any downloaded packages, and I don’t yet know how to specify a flash drive, what type of installation to use, maybe I should be running setup-bootable rather than setup-alpine?

I’m faced with a quagmire of possible directions to try from here, or start over with different settings, but so far everything I’ve tried ends up with a “typerwrite”. that is, a kind of text editor that echos back whatever I type but does nothing else. typing help, shutdown, commands of any kind have no effect. other than the keystrokes appear on the screen. Hitting the power button though, initiates a long involved shutdown… so something was up and running.

I think I may need to install the packages FIRST, before running setup, from what I can gather. but what and how?

It seems to be a fully operational, or potentially operational Alpine Linux, but with zero packages installed. So it does nothing but mimic a typewriter.

Otherwise it looks like the lights are all green!

WiFi up

Everything loaded:

Lights all green:

Hitting “none”, (which I did not do before) as suggested above, instead of trying to save anything to any disk, as I tried to do, at least results in a command prompt.

Any guidance how I might go about getting YaCy up and running on Alpine from anyone with more experience and knowledge would be appreciated.

For an NTP client for example, why chrony? Why not one of the other options? What about openssh? Why these and not some other option?

I will be diligently researching all this as I find the time, but I don’t often have a whole lot of time.

Edit: this overview, answers all of my questions that came up during basic installation:

Making some headway.

This video provides a definitive answer I think, though I haven’t finished watching:

Just an annotated screenshot:

Actual video:

so, rather than running setup-bootable INSTEAD OF setup-alpine… run both.

I shall finish this video, and maybe a few more, do some more research if necessary about installing packages and such, then take another stab at it. but this seems like a milestone to me.

Given that instructions for installing YaCy use sudo, there may be some alternative method, but I would assume this is a necessary step:

To quote:

First of all, make sure the sudo package is installed in your Alpine Linux system. By default, sudo is not installed.

To install sudo in Alpine Linux as root user, run:

# apk update
# apk add sudo

The # above, I believe is meant simply to represent the command prompt.

Most Linux distributions already have sudo installed, Alpine does not. So the instructions found here: Download - YaCy under YaCy for Linux, will result in “sudo not found”.

Alpine is very bare bones, and as YaCy runs in a browser, I assume adding firefox would also be a minimum requirement. I’m not sure if any other browsers are supported.

I don’t know as yet, if YaCy has any additional dependencies that a bare bones Alpine system would be lacking.