Leach only need help

Port 8090 forwarded to my local IP. Os firewall allow same.Tried to set up proxy. Both make me just a leach. DMZ also failed even though I do not consider that a real solution. What Am I missing. Is my ISP blocking? I’m about to just use as is. Spent at least 4 days to get this far. My last attempt to fix leach only. It’s very frustrating. I tried very hard to share! Maybe a basic router guide is needed. I notice qbitorrent has specific protocols UDP etc listed in preset rules that also make me a leach. I selected both since I have yet to find specific protocol info. Does it use UPnP? The only thing I have off besides remote management.
If I block 8090 I get no search page. So I’d say it is confirmed open by the search page.

I got YaCy working as a server today on MX Linux by configuring port forwarding through my router’s firewall.

Then I noticed, when I checked out of curiosity, that my OS firewall was never activated.

When I tried turning it on I was bumped off the peer network as a server. I have not been able to configure the firewall to get YaCy working as a server. I may keep tinkering with it but so far I have not been able to get it working with both firewalls active.

Since The router has a hardware firewall, which is generally considered better than a software firewall, I don’t think there is too much danger in leaving the OS firewall disabled.

See this article for example:


I’m not sure that’s great advice, but for me, leaving the software firewall disabled works. Since there is a hardware firewall in the router anyway. Also I’m running Linux Live on a flash drive so if there seems to be any issue I can shut down and reboot without persistence and, in theory at least, that would eliminate anything that had been picked up. Unfortunately that would also include any data added to the YaCy index for that session.

At any rate, if you do have a hardware firewall/router, It might not hurt to try turning off the OS firewall briefly to see if that is the problem.

I don’t know if there is a conflict or if I’m not configuring the software firewall properly or what but I haven’t been able to get YaCy fully operational as a server with both a hardware and a software firewall running.

I think my router is blocking a needed protocol. I tried no OS firewall. I’m at a loss. It may be an OS bug or ISP blocking. I needed a proxy to fix leach only on Qbittorrent. It could be, most refuse un-proxied connections now. I would think a VPN would count, but not so. I suspect my ISP but, VPN also is the same. Which protocol did you select on port forwarding? Both is what I selected. Qbittorrent has rules for both protocols on different ports so both was never a rule. TCP or UDP. The fact I get no search page if, I block the port, makes me think it’s open just not correctly

I set the protocol to Both. Still not sure that was necessary.

Details on exactly how I got it all working are here:

Though the process is still somewhat ongoing.

Surprisingly, I’ve had my computer shut down for two days, partly due to being busy with some house renovations and partly just to see what would happen, well, on rebooting, got a connection and YaCy is still working in sever mode, though still on the same DHCP assigned IP.

Perhaps the lease time is very long, or it’s just coincidence I was assigned the same IP or the router is “smart” enough to recognize the machine.

Additional specific info might help, like what model or brand router? Did you set up the local IP or is it DHCP assigned? A screenshot of your router settings perhaps? Your operating system?

I did come across a setting for UPnP in YaCy. It was turned on by default but had a failure to connect error. I unchecked that as I was not using it. My router also supports UPnP but it was turned off.

If it had been turned on in my router, perhaps YaCy would have connected automatically, however, from what I’ve been researching, UPnP may not be as secure as direct Port Forwarding.