Opening Router Port - ""You cannot be reached from outside"

“You cannot be reached from outside. A possible reason is that you are behind a firewall, NAT or Router. But you can search the internet using the other peers’ global index on your own search page. We encourage you to open your firewall for the port you configured (usually: 8090), or to set up a ‘virtual server’ in your router settings (often called DMZ). Please be fair, contribute your own index to the global index.”

I’ve managed to access my router using the IP address in the manual that came with it.

Now What?

I’m guessing somewhere in the Firewall settings:

This “portmapping” area, perhaps?

The device is a SPRINT WiFi “Hot Spot”. I’m not on a LAN. Or am I?

Apparently a LAN IP Address is required. The interface is not allowing me to simply open port 8090.

I can find no setting called DMZ.

I could probably figure this out. I managed doing something similar years ago to run a web server from my desktop, but that was years ago on a dial-up connection.

DHCP is on. I’m guessing that would cause the IP address of the laptop I’m running YaCy on to change periodically.

I thought this thread might be helpful to others. There are only so many different routers and configuration options.

There are also settings for UPnP, From what I’ve seen about that though, it is better to leave that turned off.

I also found this online manual for my device:|Settings%20Tab|_____5

If that helps.

I’m reluctant to mess with any settings without knowing more.

For example, there is a setting for TCP, UDP, TCP and UDP… what does YaCy require? Or are these setting even necessary?

I’m in the same boat. I forwarded port on router selected both for protocol. Opened ports in firewall. I have the same issue with Qbittorrent. I can only leach. I fixed that with a proxi server. I don’t know what I’m missing. I turned off VPN (no change). Maybe my ISP is blocking it? I’m at a loss. I won’t go DMZ (no firewall). Opening all ports is not a solution. Portal stopped working now. I cant get a search page any more. I think I’m giving up. Spent a few days too many on this. Going backwards now. I’ll wait til there are better directions. I’ll watch my distro forum for progress

I have ports open and it does not work. I changed ports lost search. put everything back device IP in router for port forwarding 8090 protocol both. OS firewall is set the same. Search works but, leach only. Guess I’ll just have to live with it. I guess it’s ISP blocking. Wish it worked on VPN’s. They can’t block that.

In my case it is not the OS firewall. Turned off still no help. So it’s either a router setting or ISP blocking. The router says ports are forwarded so it looks like the latter or my Asus surfboard sucks? Tried DMZ with no change. It’s leach only or, nothing, it would appear. It woks on VPN just the same as not.

I’m thinking that what is necessary is probably to turn off DHCP and set up an actual internal network, assigning each device a stable IP address.

I would think otherwise it would be impossible to isolate a particular machine inside the firewall/router to forward packets to.

–edit: this is wrong, see below (It is possible to set a range of IP addresses for DHCP while using a different range for static IP’s)

edit: add video:

Last time I did that was around the late 90’s on a 56K dialup connection. Turning off DHCP might be problematic, with family and friends with their own devices, and several smart phones all using the connection. I don’t know if a permanent IP adress can be assigned to one machine while allowing all others to use DHCP.

Also, last time I set up a home network was on Windows Me or XP or something. Don’t know where to begin with a mix of Windows, Linux and Smart Phones (Android) on the network.

I’m fairly certain that it could be possible to automate establishing a two way connection. Multiplayer Online games and various file sharing programs just work.

If I can set up a dedicated YaCy search spider/server I think I’d start by getting an old sacrificial computer, Install some super secure Live version of LINUX and work it out. The worst that can happen is having to reboot the system and start over. I think I would rather have a YaCy machine running just YaCy as a contribution to the community index Only using YaCy search (without opening the firewall to incoming connections) for personal use.

It seems some previous features of YaCy have been disabled. CGI for example, for running Perl scripts. was also removed from Perl’s standard distribution, not sure if there is a connection there. I suppose it is the sort of thing that could potentially be abused.

It seems SOME routers allow having a server on the internal network assigned a static IP while still using DHCP for all other devices. I don’t know yet if that is an option on my “Hot Spot”.

This video, at least explains the problem. Why YaCy “cannot be reached from outside”.

The solution, however, if there is one, could involve switching to a different internet service provider, upgrading to a plan that allows running a server, using port forwarding, but, apparently, assigning a static IP address to the machine running YaCy is necessary, though some sort of Dynamic DNS might be an option if having a static IP on one machine is not possible or is not practical.

This video provides what seems like an important clue for my particular problem. How to have a static IP for one machine while using DHCP for all other devices.

Apparently, just find what range of IP addresses the DHCP server is using and choose a static IP that is outside that range for your port forwarding.

This video provides another bit of useful information: How to find your routers ip address so as to log onto and configure the router.

Previously I got out the manual that came with the router to look it up, but it is also possible to find the router’s IP without the manual.

On Windows, use ipconfig

The router IP address will be listed as the Default Gateway.

Another useful tip: Different makes and models of routers, if never previously accessed or set-up will have, or may have a default password. This will usually be something simple like admin.

Again, if the router manual is lost or missing the default password can be found online:

That tip came from this video:

I’m going over a lot of information primarily because there are other people in the household that depend on internet access through the same router, so before mucking around and possibly messing something up and perhaps loosing internet access, I want to know exactly what I’m doing, and there is a lot to learn. In the end, my ISP may be blocking port 8090 or something but if I don’t know what I’m doing, I won’t know what’s going on anyway.

So, I study this and happen to learn something new, I’m sharing what I learn. If someone already knows this stuff, they probably won’t be wasting time reading all this anyway.

By the end I hope to be able to give some simple and direct YaCy specific and/or device/router specific information on how to get YaCy going and fully operational.

Anyway, the purpose of a “subnet mask” was always something of a mystery to me. Why is it needed, what is its purpose? I found this video that explains it rather simply and directly.

Basically it covers or masks the part of the IP address that is common to the given network and shows or reveals the part of the IP that is unique to a specific machine on a network.

For example, If my internal network consists of on one computer and on another, the only difference is the last number 101 or 102.

The subnet mask of makes it clear that the last part of the IP address is the only part that really matters on this particular internal network. A different type or class of network might use a different subnet mask such as which shows that the last two numbers of the IP(exposed by the 0’s in the subnet mask) are significant on this network.

Perhaps there is more to it than that, but this makes sense to me.


Well that was much easier than I thought. My confusion came mostly from not understanding what the router was asking for: "LAN IP Address: [ ] "

I interpreted that to mean the IP Address of the LAN. Apparently, so I thought, there must be some IP Address for the LAN, however, all that this was actually asking for was the IP Address of my computer on the internal home network, or my computers “LAN IP Address”. Not the LAN’s IP address, but the LAN IP Address of the computer being port forwarded to.

BTW, I am still running YaCy, now as a full fledged peer/server on the network LIVE from a 56 Gig USB Flash Drive.

I did however cheat and just used the IP Address assigned by DHCP for now. Not sure how long the lease will last.

So these are the settings for my Sprint ZTE Hot Spot, under “portmapping”

I don’t know if YaCy requires UDP but I selected both (TCP & UDP).

I think having a “demilitarized zone” or DMZ was used back when IPv4 addresses were abundant and still commonly used on internal networks. These days NAT with port forwarding is much more common I think.

Perhaps the notice should be changed to reflect modern usage:

“You cannot be reached from outside. A possible reason is that you are behind a firewall, NAT or Router. But you can search the internet using the other peers’ global index on your own search page. We encourage you to open your firewall for the port you configured (usually: 8090), or to set up a ‘virtual server’ in your router settings (often called DMZ). Please be fair, contribute your own index to the global index.”

I still have some issues to resolve. Like, how to assign a static IP to this computer, or flash drive on Linux. It is reassuring however to see the little notice change to a green exclamation point:


So it is possible, even on a home network using a simple WiFi “Hot Spot” and running a Live Linux OS from a USB Flash Drive.

If that is possible, I would think that practically anyone should be able to run YaCy one way or another.

I have always used reserved IPs. Can’t remember why LOL. Oh yea it was so I could use ssh and virtual machine to use pi’s headless. DHCP is on for guest only.Also needed it for Qbittorrent proxy. My router has port forwarding and DMZ listed under the advanced tab from main page. I would think a thumb drive uses the IP of the host PC. Static IP is required for port forwarding and DMZ. Maybe you need to set static to see those options on your router?

Fastest ZTE MF923 Router Open Port Instructions :// This is the search I used “Sprint ZTE Hot Spot, Port forwarding” Hope that helps you! Actually you have it set up already. Just Zoomed you pic

The system (MX Linux) is booted up directly from the thumb drive and runs entirely in RAM. There is no “host PC”. It seems a static IP is not required for port forwarding so long as the lease has not expired. I’m still running in “senior mode”, after several days, though having shut down and re-booted as well as having disconnected from the router/internet for extended periods several times. As this has been working without any problems with the original DHCP assigned address, I haven’t yet bothered to set a static IP.

Where is the ram located? Where is the Ethernet located? If it is a PC, it would be the host PC. The thumb drive is using PC Mac and maybe IP address. Not sure how it works with reserved IP’s though.
My router also looks for PC name. Name would change with a thumb drive OS. Not sure if that’s enough to cause an issue though. Since DHCP is on with reserved IP’s it should work, except for port forwarding maybe. Thumb drive may be the temporary answer though. It would rule out the OS firewall or bugs. It would have to be in the router then. I have another router I could bridge to test router too. It does not have a modem Thanks for the ideas!
You are correct, you can forward to unreserved IP’s but, why do it all again and, again. Not sure how long leases last but, it caused an issue for me before. Seemed like it was a month, if I recall correctly. It could be more too. I have had reserved IP’s for years.

I think I found a possible problem.
YaCy release notes: IPv6 routing of Peer-to-Peer network elements and overall IPv6 enhancements.
Nothing I own uses IPv6 yet. My VPN disables it. It must be IPv4 only. I’ll bet this is the problem. There is no way to port forward to IPv6 in my router also. Not sure if forwarded IPv4 covers IPv6 too. VPN’s block it because, it leaks your IP. Not sure how many IPv6 clients there are to choose from? VPN’s provide their own IPv4 DNS. They do not have IPv6 DNS. It may be I need to choose private browsing or search. Can’t have both with a VPN that disables IPv6. I think it is disabled when VPN is off too.
Looks like thumb drive until I find a more modern VPN for $2.99 a month LOL. Not going to happen lol Thanks for your help! Downloading Thumb drive now. I’ll post back for others benefit. I’ll bet this is solved.

Where did you get the thumb drive version? Found the developer page on Git Hub
Scroll to bottom for lots of info. I can only find links to ap not OS

What I’m using is not any special thumb drive version of YaCy, just the standard Linux install.

There are several “Live” versions of Linux available that will run on a thumb drive. Some in particular, like AntiX Linux were designed for it.

I’m using a fork of AntiX called MX Linux which is also designed for booting and running from a USB.

Once I had Linux running on a USB (with persistence) I was able to install various games and additional programs. Out of curiosity I tried installing YaCy to my existing MXLinux already running from a 32Gig USB. Then used MX Linux to clone the whole system to a larger and faster 3.0 56Gig USB, increasing the persistence file capacity to the maximum allowable.

Originally I had MX Linux running on a USB along with about ten other Linux distributions using Easy2Boot.

I really like Easy2Boot because once installed on a USB you can just drag and drop almost any ISO onto the Easy2Boot flash drive, as many as it can hold, then boot up whichever one you like whenever you want.

I liked MX Linux enough to clone it from there to its own USB.

Conceivably, YaCy should install on any Live Linux though MX Linux is all I have tried so far.

I think a person could also create a bootable USB for Windows, though I’m not sure why anyone would want to.

Thanks. I’m a dunce lol I’ll try it on Arrmbian. I have an unsupported version I don’t use for much. Chromium is the only browser it runs smoothly. If I uninstall it, it breaks the Ethernet connection. I hate google’s spying. That log in logo is the spy, weather you log in or not! If it works there I’ll find a better OS for it. Thanks again!