Updating latest release to snapshot


I’m curious if there is any danger in updating latest release (1.92/9000) to the latest snapshot release provided by luccioman on github: https://github.com/luccioman/yacy_search_server/releases/

I’m curious if just unpacking tar.gz and moving around “DATA” directory will run fine or if there are some issues with for example Solr update I’ve seen in the changelog of prereleases.


After a bit of chat on https://gitter.im/yacy/yacy_search_server – it looks like such update should be fine. So I’ve gone ahead with update from latest 1.92/9000 release to the latest pre-release 1.921/9828 and it looks like everything is working fine.

Yes! Thats the way it is supposed to work!

Is it working?

Yes, it is. In fact pre-release is way much better than 1.92. Not only JS-enabled sorting of returned results, but also crawler is now more what I would expect it should be. – e.g. in the log I see crawling over different sites while on 1.92 there were a ton of the same hosts printed out which puts crawler into much higher danger of being banned by the target server.
So, my current data set of ~600GB seems to be handled fine so far and still slowly growing.

:smiley: @Lucid00 did great work!
We should do a main release…


Which files of the “DATA” dictionary have you moved to the new installation?
First, I have tried by moving the entire “DATA” directory into the new destination before unpacking tar.gz.
Second, I have tried by overwriting the entire “DATA” directory after unpacking tar.gz.
Both did not work for updating from version 1.924 to version 1.926.

1 Like

@Felix there is an upgrade path to follow…
Search the forum for it.
It involves a full export of yacy index and full import of index.
I am typing this on phone.
I have used it and it works.
I believe your need to use this method every time solr version changes.

Won’t be able to have PC for some time

I’m not sure which version, but there was an update of solr engine, which is the fulltext database embeded into YaCy. The way to jump from one version of solr to another was exporting/dumping the whole index into file in the old version and importing it into newer. This ‘jump’ is neccessary just once, future upgrades are seamless. See forum here.

1 Like

Thanks to roamn and okybaca. Meanwhile I have just started a new YaCy instance from scratch with version 1.926. I did not import my older index as it was quite small.
With the new setup updates should be no problem. On ConfigUpdate_p.html administration page I got a dropdownlist with the available versions to update to.
My index is continuously growing now. My YaCy instance is called niceyacy

1 Like