Website with embedded YaCy Kiosk

I think YaCy really shines when used as a regional information Kiosk.

Porteus and YaCy compliment each other and enhance each other.

This is an attempt at a regional “Virtual Kiosk” for the Fort Plain, New York area.

It is in “portal for your own webpages” mode, which I never tried before, but it works out marvelously as a regional data-center. I’ve only done a limited crawl of a few select area websites, but I’m just getting started.

I still do not have a PROVEN Porteus+YaCy Live USB with persistent memory storage, but I’m 99.999 percent sure it is working, because I’ve been watching YaCy’s memory usage and also because this whole YaCy on a stick thing is running so incredibly fast and error free.

Previously the setup, with little persistent memory, would become dysfunctional, eventually freeze up and need to be rebooted, I couldn’t really crawl many websites as there would be no drive space etc. but now! I’ve been crawling page after page for hours at an average speed of about 120 ppm, when actively crawling. but I’m actually holding YaCy back, by keeping crawls at about 1000 pages (per craws or start page), sometimes 2000 or more, if it is a really big or important website, or one I really like, which is probably too many for keeping it local or regional.

Hopefully all this work will not be erased whenever I shut down.

I’ve been working using three or four machines simultaneously. because the Kiosk hardware itself is very limited as far as what can be done. when logged on remotely however, through an “UNBOUND” laptop or phone, there are more options available for digging deeper into the works, using browser functions not otherwise available, including browsers other than whatever is booted on the kiosk.

So I have one laptop for my domain control panel accessing the portal that way on the website, doing searches for information on another laptop or phone and running crawls on the kiosk through another phone or laptop, and this doesn’t seem to be stressing anything. I’ve actually never experienced YaCy running so lightning fast, it seems it was made for this.

Please feel free to visit the website and let me know what you think. By that I mean anyone.

I’ve been working on this all night, so I’m going to leave the USB plugged in and the kiosk running.

I actually almost get the impression that the more devices connected the more powerful the kiosk gets. Might just be my imagination, but all the hardware to some extent shares the workload.

I may wake up and start messing around some more by the time someone reads this, so if the kiosk is unavailable or acting funny, that might be why. I have a lot of ideas to try.

Anyway, this is the link, again:

I have not even begun to think about trying to boot up the Proteus Kiosk SERVER to get more kiosks going. I’m not sure it is even necessary, as there are so many ways to access it already, but I do need to get file access, probably. It would open additional possibilities. like direct editing of the css file and program files.

OK, back in business.

I did discover something new, aside from; when running YaCy on a Kiosk - save often, because if there is a crash, you will likely loose all your work, and the something is this:

Normally Porteus Kiosk does not boot up from a USB without jumping through some hoops that involve unpacking the ISO, extracting and transferring some boot files etc… Apparently. At least that is what the documentation says here:

It is, in other words necessary to create a “hybrid” USB drive that the Kiosk can boot up on.

I seem to have gotten lucky in that Easy2Boot is a multi-boot system designed to boot virtually anything. It seems by installing Easy2Boot first (many of my old USB drives kicking around already have easy2boot installed) the hybrid USB boot loader (or whatever it is Porteus Kiosk requires to boot up) is already made available.

In other words, I got lucky.

I don’t know exactly why it works, but it works.

“Normally” the Kiosk should be burned to a CD, apparently, first, then unpacked and some files transferred, (instructions above), but if you have any easy2boot usb, just use that instead. It worked for me anyway.

The utility provided in the ISO I posted a link to DOES NOT WORK to burn the kiosk directly to a USB. I tried several times. and IT will try.

It will say “Burning Kiosk - this may take some time” or some such thing, but I waited ten hours, twelve, 24 hours… (twice I tried) still waiting.

Its looking for the non-existant C.D. or waiting for the drive to spin up or something. Nothing ever happens.

Install easy2boot first and the Kiosk burns to the USB in under a minute. Its only like 300kb It should not take hours and hours. Learn the hard way or (read the instructions) but this alternative method seems to work well also. At least by all appearances. I still have to see if persistent memory is really truly working though.

I mention easy2boot a lot, but only because I do use it a lot. I’m not a salesman, its a free download:

also, I’m not putting the Kiosk onto an easy-to-boot drive, I’ve been overwriting the easy2boot drive, but it seems that the Porteus installer recognizes the presence of the bootloader on the drive and preserves the boot sector while overwriting everything else, including easy2boot and any and all files and ISOs it might have contained. Or something like that.

P.S. Also, use USB 3.0 it’s a gazillion times faster that 2.0 It is soo sooo much better and faster than 2.0 for running a Live OS on a usb.

OK, what wiseguy in here got into the system and setup an admin password before I had a chance?

I guess “In here” might not be right. but having just booted up a new install, I don’t think it should have had an admin password locking me out already. Something weird, it seems is going on.

The default browser also mysteriously changed to chrome. Also, my installation trick no longer works.

Not that I’m making any accusations, but I did not like the Kiosk installation as it requires going online immediately to download a “web browser” and then your computer is connected for the duration, which generally takes a lot of time. It all seems intentionally drawn out for the install of an ISO that is barely 200MB.

Anyway, the Kiosk crippled browser/system is barely functional on so many levels, no command line, no file access, no way to do much of anything but brows the web, but I’m starting to also realize that all the cool powerful tools and such that I’m beginning to appreciate more and more are all YaCy. YaCy does not need a “Kiosk”, any OS/web browser would serve.

Maybe I’m not being hacked and maybe the kiosk with server could be cool, but it is not of much use in terms of development and customization.

A “kiosk” is intended to lock the user out of 99% of a computers functionality to only allow limited web browsing, if that, or display of advertising. It is impossible in terms of trying to develop and customize a community datacenter. But, the “community datacenter” I had in mind would be a kind of kiosk. I think I need something slightly more functional.

Possibly Porteus Kiosk could be beefed up with additional functionality, which might be worth doing, but I don’t think I have the patience. Maybe I’ll take another look at Alpine, or some derivative or could docker be of use for this?

YaCy seemed to be running exceptionally well on Porteus for some time with no problems. Suddenly the install is hanging. I get locked out of my own kiosk and other weird inexplicable issues cropping up, like my default browser setting. just weird.

Anyway, I need a break from banging my head against the wall.